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Introduction 
 

This document will take you through step by step how to install, configure and implement the Invoice 

Automation for Microsoft Dynamics NAV by V1 standard solution. 

 

When the installation is completed, the following will be in place: 

 

DbArchive 

 

 All DbArchive tables pre created 

 All server side def files pre written 

 All supported DbScanner profiles pre-configured globally imported by the connector 

 All paths / ports / server names configured by the connector 

 DocGUID field added for all tables and def file extracts ready for V1Audit 

 FTS field added for all tables ready for Full Text Search 

 Multi-company support utilizing DBA_FILTER_MAP table configured by the connector 

 

DbCapture 

 

 All DbCapture profiles pre-configured 

 All def files pre-written 

 All paths / ports / server names configured by the connector 

 

Drilldowns 

 

 Step by step documentation on how to add the relevant buttons to screens for each of the 

supported document types. 

 

Barcode printing 

 

 Step by step documentation on how to add the relevant buttons to screens for each of the 

supported document types. A simple ini file decides what barcode printers are used 

 

Outbound 

 

 Sample report for Posted Sales Invoice ‘pre tagged’ based on NAV standards included for use 

with the DBPDF.exe (PDF splitter) 

 Sample Formulae for common document types included so they can be copied and pasted 

into a customer specific report if needed 
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Technical Pre-Requisites 
 

Please adhere to the following pre-requisites to ensure a smooth installation. If any of the following 

are unknown / not in place / in doubt, STOP.  

 

Refer to the appropriate contact before continuing. 

 

Don’t think ‘it will be OK I can carry on’, don’t skip any part or try and get round something you don’t 

think is relevant or you’ll screw it up. 

 

STOP and get the information prior to starting. 

 

Pre-requisite Contact for Enquiry 

Microsoft NAV is installed I.T Department 

At least one company is present in the NAV database I.T Department 

The SQL instance, username and password to access the NAV database are known I.T Department 

The SQL Server Browser service is running on the NAV SQL server I.T Department 

You have knowledge of at least one NAV user I.T Department 

You have access to the Development Environment client and RTC* I.T Department 

The customer has a development license that permits changes to NAV Pages** I.T Department 

You have knowledge of what V1 software is licensed for the customer*** V1 Account Manager 

You have the licenses and V1 software downloaded on the NAV Server**** V1 Admin team 

 

*Role Tailored client, the day to day UI (dark blue icon) 

 

**If they don’t this is fine, we can temporarily load ours but they’ll need to re-apply their own back 

once our work is completed 

 

***Where possible, get clarity on whether the V1 licenses are Named or con-current. The setup later 

on in this guide is dependent on which 

 

****Although the V1 server components can be installed on a separate server, you are advised 

wherever possible to install them on the same server where the NAV SQL database is located. 
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iManager & Database Setup 
 

Mandatory assumptions: 
 

 You have access to the SQL Management Studio 

 You have the SQL username and password to hand to log in to the Dynamics NAV Instance 

 The DM4.5 distribution is uncompressed and accessible in C:\V1Home\CD 

 The server you’re going to install on (whether a V1 standalone server or the Dynamics NAV 
server) is internet connected 

 
1. Open SQL Management Studio and connect to the server with the Dynamics NAV instance using the 

SQL username and password required to connect to that instance.  
2. Using the SQL Management Studio, create the following tables in the same instance as Dynamics NAV: 

  

 DbArchive 

 DbCapture 

 V1Audit 
 

3. Browse to C:\V1Home\CD, right click and run iManager.exe as administrator 

4. Click Server Components 

5. Click Extract Finereader, locate ABBYY11.exe, click OK 

 

NOTE: There is no progress bar, wait until you see the message box it has uncompressed to the 

temporary location 

 

6. From top to bottom, confirm the settings prompted. Un-tick the following components as they are not 

used as part of the integration: 

 

a. Web Server Configuration: Apache 

b. DbArchive Deposit server 

c. DbArchive Full Text Index Server 

d. DbWebQuery Configuration 

e. DbWebRetrieve Server Config 

f. DbArchive Cache Clean 

g. DbWebQuery Cache Clean 

h. DbAuthorise \ Server instances 

i. DbCapture \ PDF File Watcher (this is now handled by the integration) 

j. DbFax \ Server Instances 

 

7. When satisfied, click Install 

8. When completed, click Install Smart Suite, agree to all defaults. 

9. When completed, close the Server Components window 

10. Close iManager 

11. Re-start iManager and and click Client Components 

12. Install at least the DbLogin Admin Console on the server (although you’re advised to install all clients 

for testing purposes) 

13. Close iManager.  
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DbLogin User Setup 
 

To facilitate ease of future setup and the workflow of email notifications across the system, there are 

some mandatory users that need setting up. 

 

You are also advised to create as many day to day users as you have knowledge of now as this will 

allow company configuration to be done more easily in the following chapters. 

 

1. Load the DbLogin Admin Console, login as administrator / administrator 

2. Configure the default_user assigning all available applications. To do this, Click the tick box to the left of 

default_user and click the Keys icon at the top of the screen 

3. Right click on Live, left click on Add Application, choose Use application default settings and click OK. 

Repeat this until you see the message stating all available applications have been added. 

a. If OCR has been installed, reflect the below against DbCapture: 

 

 
 

b. Create a user called APDEPT ensuring to give an email address for the AP Department, this 

address will be informed of issues / OnHold reasons that come from users using the system 

4. Repeat the above steps for the administrator user, again giving access to all available applications. 

a. If OCR has been installed, when adding DbCapture select the option to Copy settings from 

existing user’s settings and select the default_user 

5. Create a user called ITDEPT ensuring to give an email address for the I.T Department, this address will be 

informed of issues / certain OnHold reasons from DbCapture (if installed) that come from users using the 

system. 

6. Create a user called PDFIMPORT giving it a password of PDFIMPORT (case sensitive). No email address is 

required. This user will be used to import PDF files from the PDF Pickup routine. 

7. Create a user called EDMIMPORT giving it a password of EDMIMPORT (case sensitive). No email address is 

required. This user will be used to import files from the EDM Import routine. 
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DbLogin Token Allocation 
 
Mandatory assumptions: 
 

 As many users as possible have been created in the previous chapter 

 

If the customer is licensed to use con-current licenses (i.e. a pool of licenses available on a first come, 

first server basis) skip this chapter. 

 

If the customer is licensed to use Named licenses (i.e. allocate specific users to use particular 

capability of the software), follow these steps.  

 

1. Load the DbLogin Admin Console, login as administrator / administrator 

2. Click the Padlock icon at the top of the screen. This displays all licenses available for all components 

installed. 

3. From top to bottom, click the component. When highlighted, click the Allocate button 

4. The available DbLogin users are displayed on the left, select the user wanting access to the selected 

component and click the arrow button in the middle of the screen. This moves it to the right, the action of 

doing this grants access. 

5. When satisfied, click Save 

 

Repeat the above steps for all installed components and all DbLogin users. 
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Connector 
 
A connector as its name suggests plugs the gap between a vanilla V1 install and adding / configuring 
standard integration specific files. 
 
Mandatory assumptions: 
 

 iManager server components have all been installed 

 DbLogin Admin Console ran and as many users as possible added 

 C:\V1Home is the installation path 

 The V1 distribution has been uncompressed to C:\V1Home\CD 

 The SQL Server Browser service is running on the NAV SQL server 

 Ensure any V1 clients installed on the server are closed 
 

Do not run the connector until ALL the mandatory assumptions have been met. If you do it will 
blow up and you’ve buggered the installation. 

 
1. Navigate to the portal http://support.wearev1.com/software/NAV/ and download the distribution to 

a temporary area of the server. Un-compress the contents again to a temporary area. 
2. Right click and run as administrator the Microsoft Dynamics NAV - Connector.exe at the route of the 

download 
3. As prompted, browse to the CurrentSettings.xml file (in our example this is usually in the 

C:\V1Home\CD directory) 
4. Click the List button which will go and find all the available SQL instances accessible. Select the 

instance Dynamics NAV is installed on (take a note of this) 
5. Confirm the SQL credentials and click Test. This checks that what you've supplied will allow 

connectivity 
6. You should now have a list of databases in the drop down below, select the NAV database 
7. Browse to the location of SQLCMD.exe 

 
This is usually in the “C:\Program Files\Microsoft SQL Server\110\Tools\Binn” directory 
 

8. Click Apply (this will copy a standard global dbscanner profile xml file, all the dbarchive def files, 
configure V1_SETTINGS with the values you've supplied, DbCapture profiles (does a -queueupdate) 
and defs  

9. When finished click Next > 
a. If DbCapture has been installed 

i. Confirm the location and poll frequency of the PDF Pickup importing routine, click 
Apply. 

ii. Confirm the poll frequencies for Queue management and purging of Exported 
documents, click Apply. 

10. Click Next >. For each of the companies it now finds, click Select 
11. On the left box below you'll see your DbLogin users, add them to the box to the right those you want 

access to which company. Click Save. This adds the users to the DBA_FILTER_MAP table in DbArchive. 
12. Repeat step 9 and 10 for each company in the drop down you want to give users access too. 
13. Close the connector 

 
From now on, if you re-open the connector, you’ll be given the option to add more users whenever 
you like, this is why it’s in your interest to create as many as you can initially.  

http://support.wearev1.com/software/NAV/
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DbArchive 
 
Mandatory assumptions: 
 

 iManager server components have all been installed 

 DbLogin Admin Console ran and as many users as possible added 

 C:\V1Home is the installation path 

 Connector has been ran to completion 

 
1. Load / restore the DbLogin Admin Console 

2. Click the DbArchive Table Editor button 

3. Click the Import from XML button 

4. Browse to C:\V1Home\DbArchive and select the tables.xml  

5. Wait a moment, all the standard tables should load 

6. Close the DbArchive Table Editor 

7. Click the DbArchive Import/Export button 

8. Click File > Show system tables 

9. Highlight the _LINKS table when displayed 

10. Click the Import button 

11. When prompted, browse to the _LINKS.csv file which should be in the C:\V1Home\DbArchive 

directory, click Open 

12. Close the DbArchive Import/Export window 

13. Click the DbArchive Link Editor 

14. You should see a large list of links setup as standard. More may want to be added as per the 

customer’s requirements. Any others that are required should be added here and once added, 

effective immediately. 

15. Close the DbArchive Link Editor 
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DbCapture – Profile Import 
 

Mandatory assumptions: 
 

 iManager server components have all been installed 

 DbLogin Admin Console ran and as many users as possible added 

 Connector has been ran to completion 

 
1. Load / restore the DbLogin Admin Console 

2. Click the DbCapture Profile Manager button 

3. Ensure the following is reflected:* 

 

 
 

4. Close the DbCapture Profile Manager 

5. Using the DbLogin User Setup chapter for reference, ensure for each of the DbLogin users you have 

configured, they are assigned access to them based on the Name separated by a comma. 

 

*If for some reason the above is not reflected, click on the Import button, navigate to the distribution 

download and import both the *.dbcp files in the \DbCapture\Profile directory. Click the Save icon. 
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DbCapture – Queue States 
 

Mandatory assumptions: 
 

 iManager server components have all been installed 

 DbLogin Admin Console ran and as many users as possible added 

 Connector has been ran to completion 

 The DbCapture standard profiles have been imported 
 

Once confirmed / imported, the Queue states need to be added for each DbCapture Profile. In this 

integration, there is a Queue state for each Dynamics Navision company allowing the segregation of 

Invoices based on the company. The following needs to be completed for both the NONPOP and POP 

Profiles: 

 

1. Load / restore the DbLogin Admin Console 

2. Click the DbCapture Profile Manager button 

3. Click the profile to be edited 

4. Click the Edit profile button 

5. Click the Queue states tab.  

6. Click the add button 

7. Where prompted, give the state a numerical number to represent the Company 

8. Give it a To be checked description and On hold description the NAV company name EXACTLY as it 

appears in the NAV client / database, i.e. 

 

 
 

9. Here is an example: (NOTE: When adding Queue States, ensure to add them in numerical order, the 

lowest number state first at the top.) 

 

 
 

10. When satisfied, click OK and the Save icon to commit the additions. 

11. Using the DbLogin User Setup chapter as a reference, assign your users the queue states in the 

DBCStatesAllowed cell separating multiple companies with a comma: 
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V1Audit 
 
Mandatory assumptions: 
 

 iManager server components have all been installed 

 DbLogin Admin Console ran and as many users as possible added 

 Connector has been ran to completion 

 You know the SQL credentials 

 
1. Open the SQL Management Console and login with the supplied SQL credentials 

2. Extend the tables which should look like this: 

 

 
 

NOTE: If the tables do not display, ensure the database has been initialized properly. 

Open the C:\V1Home\DbAudit\DbAuditServer.exe.config file in a suitable text editor and 

ensure the connection string matches the equivalent settings as displayed when connecting 

using the SQL Management Studio. If changed, save the file, restart the DbAudit and 

‘DbArchive SQL Write Server:31417’ to force the re-creation. 

 

3. Edit the V1Audit\dbo.CaptureProfileToSupplierMap table and add the following: 

 

 
 

4. Close the SQL Management Console 
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V1 SmartMail 
 
Mandatory assumptions: 
 

 iManager server components have all been installed 

 C:\V1Home is the installation path 

 A mail server is accessible and the credentials to access a mailbox known 

 The server name is http://NAVSERVER2017 (change where appropriate) 
 

SmartMail is a highly configurable facility to poll a specific mail server (POP3 or IMAP) for a / 
mailbox(es) for attachments and when found, extract them to a known location on the server. 
 
The customer is advised to create a mailbox on the mail server specifically for Invoices that are sent to 
them electronically by suppliers. In our example, we assume these are PDF’s and that the email address 
is pdf@wearev1.com 
 
When received, these PDF’s are automatically imported into DbCapture with no user intervention 
required. The mail box is not monitored and only used for this purpose. 
 
NOTE: At steps 17 and 19 the paths given are suggested only. Whichever path is chosen, ensure those 
directories are manually created / exist prior to using the system. 
 

1. Navigate to the V1 distribution, open the SmartSuite directory and run the SmartMailInstaller.MSi 
agreeing to the defaults. 

2. Using an administrative cmd prompt, cd /d C:\V1Home\SmartMail 
3. Run this command: 

 
node.exe src/app.js config 

 
4. This should load a cmd window, minimize it 
5. In your web-browser of choice, navigate to http://NAVSERVER2017:8444 
6. Set the Poll time in seconds to be 30 
7. Set the Cycle mailBoxes value to be run continuously  
8. Click the edit icon below Mail Servers and add you mail server, give it a Server ID 
9. Click Add New Mailbox button 
10. Give it an identifier of ‘DbCapture PDF Imports’ 
11. Align the server ID with the one assigned at step 8 
12. Enter the email address to be used 
13. Enter the password to authenticate this email address 
14. Tick the Enabled? Tick box 
15. Select an Action of EXTRACT 
16. Add PDF as an extension 
17. Give an attachment path of C:\V1Home\SMARTMAILS\PDFS 
18. Click the [+] and add an action of SAVEMSG 
19. Give it a Saved message path of Give an attachment path C:\V1Home\SMARTMAILS\EMAILS 
20. Tick the middle 2 options, leave the first and last un-ticked 
21. Add an Action of DELMSG 
22. Click OK 
23. Click Save Configuration 
24. Close the cmd window opened at step 4 
25. Start the V1 Smart Mail service 

 
  

http://navserver2017/
mailto:pdf@wearev1.com
http://navserver2017:8444/
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Our example will give this scenario: 
 

 Every 30 seconds, PDF attachments are extracted (along with the email(s) and a tag file 
containing information about it) from pdf@wearev1.com 

 The emails are copied to C:\V1Home\SMARTMAILS\EMAILS and the PDF attachments that go 
with them are copied to C:\V1Home\SMARTMAILS\PDFS 

 The message is deleted from the mail server (this is necessary or the message will be 
downloaded over and over again) 

 The PDF Pickup service is polling the C:\V1Home\SMARTMAILS area, when it finds a PDF 
imports it in to the nominated OCRIMPORT directory. To change this at any time, edit the 
C:\V1Home\DbCapture\defs\V1_SETTINGS_OCR.def and the PDFPICKUP_OUTPUT variable. 

 When the PDF is imported and the DbCapture Queue ID is established, the email file itself is 
copied to the same directory. This is then archived in the Attachments – Email DbArchive table 
when the Invoice is imported in to Dynamics NAV. 

  

mailto:pdf@wearev1.com
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Drilldowns 
 
Mandatory assumptions: 
 

 iManager server components have all been installed 

 DbLogin Admin Console ran and as many users as possible added 

 C:\V1Home\CD is the distribution path 

 C:\V1Home is the installation path 

 Connector has been ran to completion 

 You know the SQL credentials 
 
What you’re going to do now is effectively add content to all the supported pages in the NAV interface 
we want drilldowns on and the ability to print a barcode, for example on the Purchase Invoice Page: 
 

 
 
The procedure is split in to 2 tasks: 
 

 Task .1. 
Using the Development Environment, add the buttons and the code beneath them so they 
launch SmartRetrieve / SmartDeposit / Print a Barcode depending on which is clicked 
 

 Task .2. 
Using the Role Tailored Client, adjust the position of the Action Bar so it’s promoted to the 
HOME Ribbon. 

 
This procedure is a bit fiddly and time consuming, but only needs to be done once.  
The drilldowns will appear for all users permitted to access the relevant Pages. 
 
You should allow a few hours to do this. 
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Task .1. – The Development Environment 
 

1. Open the Microsoft Dynamics NAV 2017 Development Environment 

 

 
 

2. When prompted, enter the SQL credentials you’ve been using, click OK 

 

 
 

3. If the customer has a development license, continue to step 4, if not: 

a. Ensure they have a backup of their .flf file 

b. Go to Tools > License Information > Click Upload 

c. Browse to the C:\V1Home\utils and select 5484587.flf 

d. It should confirm the license has been uploaded successfully 

e. Close the license information window. 

 

NOTE: As per the pre-requisites, ensure when you have finished this procedure, the customers 

own license is reinstated. 

 

4. Go to Tools > Object Designer (Shift + F12), maximize the window 

5. Click on Page on the left 

6. Find 51 and highlight the row by clicking to the left of 51 

 

 
 

7. When highlighted, click the Design button at the bottom 

8. Go to View > Page Actions (CTRL + ALT + F4) 

9. A button on a screen is classed as an ‘Action’ so we now have to add the Actions we wish to display: 
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10. Scroll to the bottom line, click in the first cell and using the dropdowns, reflect the above screenshot 

tabbing between each cell as you move from left to right. 

 

NOTE: Ensure to align the ActionGroup at the same vertical position as those currently in the list. You 

can change the alignment by highlighting the line and using the buttons on the bottom right of the 

screen: 

 
 

11. Once the ActionGroup and all the Actions from the above screen shot have been added, click on the 

Caption column cell of the V1 Document Management ActionGroup row and press SHIFT + F4. Reflect 

the below: 

 

 
 

12. For each of the Action rows listed below; click on the Caption column cell, press SHIFT + F4 and  assign 

the setting for the row listed below. For each Action, set the Promoted flag to Yes. For those Actions 

marked below with a *, also set ‘PromotedIsBig’ to ‘Yes’: 

 

Name / Caption Tooltip Image 

View Document* Click here to launch SmartRetrieve and view this document View 

Deposit Document* Click here to launch SmartDeposit and deposit a document against this or any other transaction Archive 

Print Barcode Click here to Print a Barcode for this transaction Print 

View Misc. Attachments Click here to launch SmartRetrieve and view attachments to this document View 

View Email Attachments Click here to launch SmartRetrieve and view email attachments this document Email 

 

Repeat step 12 again for each Action, but this time selecting the Name column cell, instead of Caption 
column cell, of each.  
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13. When all Actions have been created, each needs code behind them so otherwise they are not visible / 

usable from within the NAV interface. Staying on the Action Designer window, go to View > C/AL 

Globals (F9) 

14. Add a new variable MyFile with a DataType of File 

15. Close the C/AL Globals window which takes you back to the Page Designer window 

16. Click on the View Document text on the Name column, it now needs code behind it or it won’t show 

up in the NAV interface. Click on View > C/AL Code (F9) and reflect everything below: 

 

Code key: 

 

 Change the text in blue appropriate to the paths, server name, internal name of the 

DbArchive table* and the company names where appropriate.  

 Ensure anything starting HYPERLINK is all on one line 

 If the Dynamics NAV company name you’re logged in as has spaces in the name, the spaces 

are represented as %2520, e.g. PETES COMPANY 123 would be written in code as 

PETES%2520COMPANY%2520123  

 

*The DbArchive table is the same name as the NAV Page with underscores as spaces, so Sales 

Invoices is SALES_INVOICES, Purchase Invoices is PURCHASE_INVOICES and so on. Use the DbArchive 

Table Editor plug-in in DbLogin Admin Console for clarity. 

 
View Document - OnAction() 

 

HYPERLINK('http://nav2017dev:5002/retrieve/results/retrieveErp/AS/PURCHASE_INVOICES/DBA_FILTER_FIELD%7C%7C~~%7C%7Cequ

als%7C%7C~~%7C%7CCRONUS%2520UK%2520Ltd/INV_NUM%7C%7C~~%7C%7Cequals%7C%7C~~%7C%7C'+"No."+''); 

 

Deposit Document - OnAction() 
 

HYPERLINK('http://nav2017dev:5002/deposit'); 

 

Print Barcode - OnAction() 
 
CLEAR(MyFile); 
 
MyFile.TEXTMODE(TRUE); 
MyFile.WRITEMODE(TRUE); 
 
MyFile.CREATE('C:\V1Home\BCPRINTING\'+"No."+'-BC.txt'); 
MyFile.WRITE('N'); 
MyFile.WRITE('q450'); 
MyFile.WRITE('A50,18,0,2,1,1,N,"Purchase Invoice - '+"No."+'"'); 
MyFile.WRITE('B40,57,0,1,2,10,80,N,"'+"No."+'"'); 
MyFile.WRITE('A50,147,0,2,1,1,N,"'+COMPANYNAME+'"'); 
MyFile.WRITE('A50,174,0,2,1,1,N,"'+"Buy-from Vendor Name"+'"'); 
MyFile.WRITE('A50,201,0,2,1,1,N,"'+"Buy-from Vendor No."+'"'); 
MyFile.WRITE('P1'); 
MyFile.WRITE(''); 
MyFile.WRITE('N'); 
MyFile.CLOSE(); 
 
MESSAGE('Your barcode has been printed for Purchase Invoice '+"No."+' for the '+COMPANYNAME+' company. Please Affix 
to your paper copy and scan in using DbScanner selecting the Purchase Invoice Scanner Profile.'); 
 
View Email Attachments - OnAction() 
HYPERLINK('http://nav2017dev:5002/retrieve/results/retrieveErp/AS/ATTACHMENTS_EMAIL/DBA_FILTER_FIELD%7C%7C~~%7C%7Cequ
als%7C%7C~~%7C%7CCRONUS%2520UK%2520Ltd/TRANS_NUM%7C%7C~~%7C%equals%7C%7C~~%7C%7C'+"No."+''); 
 
View Misc. Attachments - OnAction() 
HYPERLINK('http://nav2017dev:5002/retrieve/results/retrieveErp/AS/ATTACHMENTS/DBA_FILTER_FIELD%7C%7C~~%7C%7Cequals%7C
%7C~~%7C%7CCRONUS%2520UK%2520Ltd/TRANS_NUM%7C%7C~~%7C%equals%7C%7C~~%7C%7C'+"No."+''); 
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17. Save and close your amendments, ensuring at the prompt that the ‘compile’ checkbox is 

ticked. Closing the Code Unit Editor will return you to the main Object Designer screen  

 
18. Click on Codeunit on the left hand side 

19. From the list, find Purch.-Post (usually has an ID of 90), click on it and click Design 

20. In the code, find this (usually around line 105): 

 

IF NOT InvtPickPutaway THEN BEGIN 
  COMMIT; 
  UpdateAnalysisView.UpdateAll(0,TRUE); 
  UpdateItemAnalysisView.UpdateAll(0,TRUE); 
END; 

 

Copy and paste this below it on the next line after the END;: 

 
OnAfterPostPurchaseDoc( 
  Rec,GenJnlPostLine,PurchRcptHeader."No.",ReturnShptHeader."No.",PurchInvHeader."No.",PurchCrMemoHeader."No."); 
IF PurchHeader."Document Type" = PurchHeader."Document Type"::Invoice THEN BEGIN 
CLEAR(MyFile); 
MyFile.TEXTMODE(TRUE); 
MyFile.WRITEMODE(TRUE); 
MyFile.CREATE('C:\V1Home\INVOICEUPDATE\'+ COMPANYNAME() +'\'+ "No."+'.txt'); 
MyFile.WRITE("Last Posting No."); 
MyFile.CLOSE(); 
END; 

 

21. Compile and save your amendments, exit the Development Environment. 
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Task .2. Adjust them for optimal display in the Role Tailored Client 

 

In this example we will do Purchase Invoices. You must repeat this procedure / principal for each of 

the Pages you added in Task .1. 

 

NOTE: Any adjustments made in the RTC will be reflected in the same pages for the web client. 

 

1. Open the RTC (dark blue icon) 

2. In the search box on the top right, type in Purchase Invoices, when found click it 

3. Double click on any Purchase Invoice in the list 

4. Click the blue drop down icon top left of the screen and select Customize Ribbon 

 

 
 

5. You’ll see two columns, those on the left are those available, those on the right those 

promoted for use. You should see V1 Document Management in the right column. Click on 

each and move them as high as they’ll go using the Move up button as indicated in the 

example: 
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6. Click OK 

7. The Page will reload and you should now see your drill downs. 

 

Repeat the above steps 2 > 7 for each of the Pages you configured in Task .1. 

 

All changes made for the Role Tailored client are also reflected for the web client. 
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Web-Service Configuration 
 
Mandatory assumptions: 
 

 iManager server components have all been installed 

 DbLogin Admin Console ran and as many users as possible added 

 C:\V1Home is the installation path 

 Connector has been ran to completion 
 
In order to either create a new NONPOP Purchase Invoice, convert an Order to a Posted Purchase 
Invoice or import natively attach images, web-services need setting up. 
 
This is split in to 4 tasks: 
 

 Task .1. – Import the Fobs 
 

 Task .2. – Activate / Check SOAP Services are enabled 
 

 Task .3. – Create the Web Service entries 
 

 Task .4. – Edit the Companies.xml file 
 
 
 
 
  



Invoice Automation for Microsoft NAV – Server Installation Guide 23 

Task .1. – Import the Fobs 

 
A .FOB-file (Financial Object file) is a binary containing one or more Dynamics NAV objects. 
 
In order to convert an Order to a Posted Purchase Invoice in DbCapture (the POP profile) or import 
natively attached images, 2 CodeUnits must be imported: 
 

1. Open the Microsoft Dynamics NAV 2017 Development Environment 

 

 
 

2. When prompted, enter the SQL credentials you’ve been using, click OK (if you’re not 

prompted, go to File ) 

 

 
 

3. If the customer has a development license, continue to step 4, if not: 

a. Ensure they have a backup of their .flf file 

b. Go to Tools > License Information > Click Upload 

c. Browse to the C:\V1Home\utils and select 5484587.flf 

d. It should confirm the license has been uploaded successfully 

e. Close the license information window. 

 

NOTE: As per the pre-requisites, ensure when you have finished this procedure, the 

customers own license is reinstated. 

 

4. Go to Tools > Object Designer (Shift + F12), maximize the window 

5. Click the CodeUnits button 

6. Click File > Import … 

7. From the downloaded distribution, navigate to the Fobs directory and select 

DownloadAttachment, click Open, Click OK 

8. Repeat steps 6 and 7 selecting POPCodeUnit.fob (codeunit name ‘PurchaseOrder’). 

9. Assuming there are no conflicts, you should then see them in the list and can close the NAV 

Development environment. 
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Task .2. – Activate / Check SOAP Services are enabled 
 

1. Open the Dynamics NAV 2017 Administration client 
 

 
 

2. Double click on instance of Dynamics NAV 
 

 
 

3. Click the down arrow next to the SOAP Service 
 

 
 

4. Ensure the tick box for Enable SOAP Services is ticked 
a. If it is, close the Dynamics NAV 2017 Administration client and go to Task .3. 
b. If not, click the Edit button, tick it and click Save. Close the Dynamics NAV 2017 

Administration client. Before continuing to Task .3, ensure to restart the Microsoft 
Dynamics NAV Server [Instance Name] service. 
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Task .3. – Create the Web Service entries 
 

1. Open the Role Tailored Client (dark blue icon) as an administrative user 
2. In the search box at the top right of the screen, type Web Services and click on it when 

displayed 
3. Click the New button 
4. When prompted, give an Object Type of Page, press Tab 
5. When prompted, give an Object ID of 51, press Tab 
6. Double click in the Service Name column for the row and give it a service name of 

Create_Purchase_Invoice (obey the case sensitivity) 
7. Tick the Published tick box 
8. Click OK 
9. Click the Refresh button and the new Web Service should show in the list.  
10. Click the globe icon next to the SOAP URL 

 

 
This should launch your browser of choice displaying the following: 

 
 

11. This is an indication it is now available 
12. Return to the Role Tailored Client Web Services Page 
13. Again click the New button 
14. When prompted, give an Object Type of CodeUnit, press Tab 
15. When prompted, give an Object ID of 60001, press Tab 
16. Give it a Service name of PurchaseOrder (all one word) 
17. Click OK 
18. Again click the New button 
19. When prompted, give an Object Type of CodeUnit, press Tab 
20. When prompted, give an Object ID of 60002, press Tab 
21. Give it a Service name of IncomingDocumentFiles (all one word) 
22. Click OK 
 
Now proceed to Task 4. 
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Task .4. – Edit the Companies.xml file 
 
Mandatory assumptions: 
 

 iManager server components have all been installed 

 C:\V1Home is the installation path 

 Connector has been ran to completion 
 

1. Navigate to C:\V1Home\DbCapture\Upload 
2. Edit Companies.xml in a suitable text editor (Notepad++ is recommended) 
3. For each of the companies to be used, enter them in this file beneath the last </xs:schema> in 

a <Values> wrapper exactly as they appear in the company selection dropdown and give them 
a 3 digit integer: 

 

 
 

 
4. So in this example, it would look like this: 

 

 
 

5. Ensure the <Key> value matches the Queue State assigned during the DbCapture Profile setup 
in an earlier chapter. When changed, save the file. 
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Barcode Printing 
 
Mandatory assumptions: 
 

 iManager server components have all been installed 

 DbLogin Admin Console ran and as many users as possible added 

 C:\V1Home is the installation path 

 Connector has been ran to completion 

 The Microsoft NAV server is called NAVSERVER 

 The barcode printer is called Zebra-Dev 
 
Barcode printing is available on all supported Pages by clicking the appropriate button that is now 
setup on the Pages. 

 
When affixed to the paper document it relates to and scanned / exported using the associated 
DbScanner profile, it will be indexed and then viewable using the View Document button on the same 
screen. 
 
The action of clicking the Print Barcode button creates a small meaningfully named txt file on the V1 
server in the C:\V1Home\BCPRINTING directory, the text file contains information scraped from the 
screen and the environment. 
 
The C:\V1Home\BCPRINTING directory is polled by the EDM Print Management service (installed by 
the connector) every 5 seconds, when a text file found, it fires a scripting file which given the path to 
the text file formats it and copies it the printer as found in the following ini file: 
 

 C:\V1Home\Process\EDMPrintManagement\EDMPrintManagement.ini 
 
This can be enhanced as a bespoke to include per user / per document type to allow for multiple 
printers, but the standard solution will work out the box. 
 

1. Install / share your barcode printer(s) on the nominated PC that wants to use it 
2. Ensure the NAV server can ‘see’ the share using file explorer (if needed the drivers for the 

Zebra GKD 420d are in the utils directory in C:\V1Home\) 
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3. On the server, to test you can now print something, copy the following text into a text file 
called test.txt and copy it to the c:\temp directory 

 
N 

q450 

A50,18,0,2,1,1,N,"Purchase Invoice - 1001" 

B40,57,0,1,2,10,80,N,"1001" 

A50,147,0,2,1,1,N,"CRONUS UK" 

A50,174,0,2,1,1,N,"WoodMart Supply Co." 

A50,201,0,2,1,1,N,"44127904" 

P1 

 

N 

 

4. Open a cmd prompt and enter this command (replace the text in red with your actual paths): 
 

copy c:\temp\test.txt \\NAVSERVER\Zebra-Dev 
 

5. You should now have a barcode label that looks like this: 
 

 
 

6. Now you’ve tested it, you need to check 
C:\V1Home\Process\EDMPrintManagement\BCPRINTER.ini reflects the above, alter the 
following as appropriate: 
 
[SETTINGS] 
PRINTER="\\NAVSERVER\Zebra-Dev" 
 

7. Restart the ‘EDM Print Management’ service 
 
Barcode printing is now ready to go. 
 
Alerts 
 
If there is an issue printing, the I.T Department are informed via email so they can take the relevant 
action. This alert can be turned on / off by flipping a variable in the 
C:\V1Home\Process\EDMPrintManagement\Print_Pickup_BARCODEDEFAULT.def file which handles 
the process: 
 
VARIABLE=EMAILADMINONFAILURE,,"1" 
 
Set this to 0, save it, they won’t then receive an alert. 
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Outbound Configuration 
 
Mandatory assumptions: 
 

 iManager server components have all been installed 

 DbLogin Admin Console ran and as many users as possible added 

 C:\V1Home is the installation path 

 Connector has been ran to completion 

 The Microsoft SQL Server Report Builder is installed 
 
In combination with an appropriately configured NAV report, existing NAV documents can be archived 
as PDF’s AND distributed to the contact email address of the transaction. 
 
To configure the reports, using a Posted Sales Invoice as an example, use the following procedure: 
 

1. Open the RTC (dark blue icon) 

2. In the search box on the top right, type in Report Layout Selection, when found click it (it 

may a few moments to load the reports) 

3. In the drop down, select the company 
4. Scroll down to 206 (Sales Invoice) 
5. In the drop down in the Selected Layout column, change it to say Custom Layout  
6. The Custom Report Layouts page opens, click New 
7. Tick the box to insert RDLC layout, click OK 
8. It should now be in the list. Click the Edit Layout button 
9. Wait a moment and the SQL Report Builder should load and the default Sales Invoice report 

appear. 
10. Click the Insert tab at the top 
11. Click the Text Box icon and drag a rectangular box the full width of the header section of the 

report in the white space between the last <<Expr>> and the start of the columns in bold. 
12. In the text box copy and paste the following (changing the text in red to match the actual 

company name as it appears in NAV: 
 
="~~!:~~@[$GUI:0]~~@[$TABLE:POSTED_SALES_INVOICES]~~@[DBA_FILTER_FIELD:CRONUS UK] 

~~@[ARCH_USER:"+User!UserID+"]~~@[ARCH_DATE:"+Globals!ExecutionTime+"]~~@[INV_NUM:"

+Code.GetData(12,1)+"]" 

 
13. Again right click on the text box, this time select Text Box properties … Select Font, set it to 

4pt with a color of white. 
14. Again right click on the textbox, this time select … Expression, click OK. This will convert the 

content of the Text Box to a formulae rather than just text (it will display as <<Expr>>, this is 
an indication it has done so successfully.) 

15. Click OK 
16. Click the save icon at the top left hand side and check it compiles, nothing will apparently 

happen if there are no errors, close the Report designer. 
17. You should see a message box prompting you to now commit the changes, click Yes 
18. Double click on copy of Built-in report and change the description to V1 Document 

Management, click OK 
 
Consult the OutBound crib sheet for more information on how to now test the report. 
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Report Expressions 
 
Mandatory assumptions: 
 

 iManager server components have all been installed 

 DbLogin Admin Console ran and as many users as possible added 

 C:\V1Home is the installation path 

 Connector has been ran to completion 
 
Once comfortable with the outbound configuration, the following reports can be configured and 
supported as standard. (NOTE: For each, change the text in red to match the company you are 
configuring): 
 

NOTE: These are just examples, depending on the location of the customers’ actual Report 

data, you may need to adjust the .GetData values. 

 
116 – Statement 
 
="~~!:~~@[$GUI:0]~~@[$TABLE:CUSTOMER_STATEMENTS]~~@[DBA_FILTER_FIELD:CRONUS 

UK]~~@[OUTBOUND:1]~~@[ARCH_USER:"+User!UserID+"]~~@[ARCH_DATE:"+Globals!ExecutionTi

me+"]~~@[CUSTOMER_NO:"+Code.GetData(10,1)+"]~~@[STARTING_DATE:"+First(Fields!StartD

ate.Value, "DataSet_Result")+"]~~@[ENDING_DATE:"+First(Fields!EndDate.Value, 

"DataSet_Result")+"]" 

 
405 – Order 
 
="~~!:~~@[$GUI:0]~~@[$TABLE:PURCHASE_ORDERS]~~@[DBA_FILTER_FIELD:CRONUS 

UK]~~@[OUTBOUND:1]~~@[ARCH_USER:"+User!UserID+"]~~@[ARCH_DATE:"+Globals!ExecutionTi

me+"]~~@[ORDER_NUM:"+Code.GetData(16,1)+"]" 

 
206 – Sales Invoice 
 
="~~!:~~@[$GUI:0]~~@[$TABLE:POSTED_SALES_INVOICES]~~@[DBA_FILTER_FIELD:CRONUS 

UK]~~@[OUTBOUND:1]~~@[ARCH_USER:"+User!UserID+"]~~@[ARCH_DATE:"+Globals!ExecutionTi

me+"]~~@[INV_NUM:"+Code.GetData(12,1)+"]" 

 
NOTE: Only the Sales Invoice report is setup out the box. For all additional reports to be used, the 

C:\V1HOME\DbArchive\V1EDD.def will need to be configured accordingly by Professional Services. 
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Post Install Checklist & Final Steps 
 
Mandatory assumptions: 
 

 All steps in this document have been completed 

 C:\V1Home is the installation path 
 
The following is a checklist of best practice steps to ensure the system is ready for ‘Go Live’ following 
the installation and configuration of the standard solution in the previous chapters. 
 
Shares: 
 

 Ensure the Barcode printer can be ‘seen’ as a share from the server 

 Create a share of the C:\V1Home\OCRIMPORT directory accessible by all users 

 Create a share of the C:\V1Home\EDMIMPORT directory accessible by all users 

 Create a share of the C:\V1Home\OUTBOUND directory accessible by all users 

 Create a share of the V1 distribution so clients can use iManager to self-install 
 
Services: 
 

 Ensure the following services are assigned ‘logon as a service’ users, preferably those with an 
administrative function: 

 
DbCapture: PDF Pickup 

DbCapture: Queue Management 

EDM Print Management 

DbArchive: EDM Import 

DbArchive: Native Document Archiving 

 

 Given the reliance on external sources such as SQL server, it’s advisable to set the startup 
type on all Db* and V1* services to Automatic (Delayed Start) 

 Assuming configured, ensure the V1 SmartMail service is started 

 Ensure the following service logs on as a NAV user who has access to all the companies 
intended for use by the integration: 

 
DbCapture: Export 

 
NOTE: When / if changed you will need to restart the service(s) to apply the permissions. 
 
Paths: 
 

 Ensure all *.defs in the C:\V1Home\DbArchive contain valid paths / ports 

 Ensure all *.defs in the C:\V1Home\DbCapture\defs contain valid paths / ports 

 Ensure all *.inis in the C:\V1Home\DbCaptureFileWatcher contains valid paths 

 Assuming 30 seconds as a poll frequency, ensure the C:\V1Home\OCRIMPORT directory is 
created within that period of time. Check the C:\V1Home\logs directory for a 
DbCapture_PDF_Pickup.log 

 Using the DbLogin Admin Console, click the Applications plugin and ensure all the Server tags 
reflect the environment(s) to be used. You’re advised to Test the connectivity to each. 
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Registry: 
 

 Ensure the following path: 
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\DbAuditServer-11000\Settings 
Has the correct SQLConnect key details to authenticate to the V1Audit database 

 
 
 


